home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 12-05-2017, 02:07 PM   #276
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by Stiggy Pop View Post
didn't you put real injectors in it?

If not come back and get the orange tops I offered up with the turbo.
I did, and a real pressure regulator. Thanks for the offer.
__________________
I don't know what I have
Cwazywazy is offline   Reply With Quote
Old 12-05-2017, 04:59 PM   #277
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Found an old 90 degree 4an fitting so the leak is fixed. Engine bay pics, admire my ziptie skills.



Cwazywazy is offline   Reply With Quote
Old 12-05-2017, 10:20 PM   #278
MrBrown
You like popsicles?
 
MrBrown's Avatar
 
Join Date: Mar 2011
Default

Any boost creep updates?
__________________
GhettoFab build thrizzie

Last edited by MrBrown; 12-05-2017 at 10:21 PM.. Reason: Didn’t read prior post
MrBrown is offline   Reply With Quote
Old 12-05-2017, 10:40 PM   #279
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by MrBrown View Post
Any boost creep updates?
Haven't looked into it. 12psi doesn't worry me too much, but I'd rather not go there without a wideband yet.
Cwazywazy is offline   Reply With Quote
Old 12-08-2017, 02:02 PM   #280
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Snow tires and a piece of the old exhaust. Much quieter now. Exhaust dump before the axle is a no-no for interior noise.


Cwazywazy is offline   Reply With Quote
Old 12-13-2017, 12:48 AM   #281
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Wideband is in. Still need to wire in the oil gauge and lighting. Getting around 15:1 idling and cruising, around 11-12 at WOT.



Also tried to figure out this doohickey. Loaded a 511 bin as a base but I couldn't get it to do anything other than sputter for a few seconds. Turns out I broke off a pin inside the socket on the ECU board, from the socket booster..



Dealt with the old engine.

Cwazywazy is offline   Reply With Quote
Old 12-15-2017, 10:00 PM   #282
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default



New side project. 1990 240 M47 with goodies like IPD sways and e codes. Sat for almost 2 years and all I did was dump in some good gas and a charged battery. Fired right up and drove home.
Cwazywazy is offline   Reply With Quote
Old 12-15-2017, 10:08 PM   #283
esmth
dirty swede
 
esmth's Avatar
 
Join Date: Jul 2016
Location: Massachusetts
Default

I want headlight covers like that. Also nice touch with the dunk's coffee, lol
__________________
1991 244 +T LH2.4 m46 291k miles with B cam advanced 4*, 962 fuel & 148 ezk, T5 white injectors, 2.5" exhaust w/ magnaflow straight-through & some kaplhenke suspension goodies
esmth is offline   Reply With Quote
Old 12-15-2017, 10:14 PM   #284
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by esmth View Post
I want headlight covers like that. Also nice touch with the dunk's coffee, lol
They're for sale if ya want em. One tab is broken off the driver's side but it seems to stay on fine.
Cwazywazy is offline   Reply With Quote
Old 12-15-2017, 11:58 PM   #285
Stiggy Pop
Board Member
 
Stiggy Pop's Avatar
 
Join Date: Feb 2011
Location: Granville, MA
Default

That car was a good buy for the price
__________________
'79 242
943 pickup
Stiggy Pop is offline   Reply With Quote
Old 01-02-2018, 09:27 AM   #286
petiww
Board Member
 
petiww's Avatar
 
Join Date: Aug 2011
Location: Hungary
Default

Oh damn, I hope my +T is going to be smooth... Good score on the another wagon!

I want to ask about your steering issue... Mine did this once a few weeks ago, only for about a minute until i parked the car. When i headed home afterwards, there were absolutely no issues.
Have you found out anything about this? I suspect its column/u-joints related, but what the heck?
__________________
1980 Brown 244 GL
petiww is offline   Reply With Quote
Old 01-02-2018, 01:49 PM   #287
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by petiww View Post
Oh damn, I hope my +T is going to be smooth... Good score on the another wagon!

I want to ask about your steering issue... Mine did this once a few weeks ago, only for about a minute until i parked the car. When i headed home afterwards, there were absolutely no issues.
Have you found out anything about this? I suspect its column/u-joints related, but what the heck?
The old rack on this car gave me some weird issues. I've since swapped it for a worn ZF rack from my old wagon, only issue with that is a little bit of play. The old rack was weird, it was like it had play in it but it took a little force to "move" I guess. So I'd turn into a corner and the wheels would turn the other direction a little bit, requiring me to turn the wheel a bit more to keep going in the same line.

Anyway, car has well over a thousand miles since rebuild and my only current issue is that it'll randomly "hiccup" for a split second, and the wideband will go dead rich. This happens like, maybe every few miles, at most.
Cwazywazy is offline   Reply With Quote
Old 01-02-2018, 08:10 PM   #288
MrBrown
You like popsicles?
 
MrBrown's Avatar
 
Join Date: Mar 2011
Default

Mines does that same crap it more frequent. I have been chasing and troubleshooting but to no avail. I believe it will be sorted out after the mega squirt goes in.
MrBrown is offline   Reply With Quote
Old 01-02-2018, 08:21 PM   #289
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by MrBrown View Post
Mines does that same crap it more frequent. I have been chasing and troubleshooting but to no avail. I believe it will be sorted out after the mega squirt goes in.
It just started happening a few days ago. I haven't done any troubleshooting (Or fixing existing problems) because of the cold. Plus the wagon I just bought needs work as well. It drives okay, but there's a killer intermittent whine, needs a motor mount, and the brakes are awful. The pedal goes almost to the floor and I don't think the front right brake does anything at all. (The left will lock up if I stand on the pedal.)

Oh, and I stole the ecodes off the new wagon for the turbo. They're way better than the plastic ones, but they could benefit from better wiring. And I've never been able to get LEDs to work on all 4 blinkers. I've tried a couple "LED friendly" relays which just straight up don't work.

I'd kill for a heated garage.

Last edited by Cwazywazy; 01-02-2018 at 08:29 PM..
Cwazywazy is offline   Reply With Quote
Old 01-02-2018, 08:28 PM   #290
Uncleknucklez
bruspeed
 
Uncleknucklez's Avatar
 
Join Date: Apr 2006
Location: Sacramento, CA
Default

I had a reman MAF that caused weird reading on my WB gauge (lots of hunting for afr and what not, rich cruise) a cleaned Bosch junkyard unit did the trick.
__________________
1980 242 Turbo
2004 V70R

Uncleknucklez is offline   Reply With Quote
Old 01-02-2018, 08:30 PM   #291
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by Uncleknucklez View Post
I had a reman MAF that caused weird reading on my WB gauge (lots of hunting for afr and what not, rich cruise) a cleaned Bosch junkyard unit did the trick.
I was planning on cleaning mine. I have some extras I can try as well, and a 3 inch off a 960 that I haven't tried with the wideband yet.
Cwazywazy is offline   Reply With Quote
Old 01-07-2018, 10:42 PM   #292
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Issues update. Shower me with brick knowledge.

I'm still having the random rich spike. I've cleaned the MAF and replaced it. Neither made a difference. Don't really know what to check next.

I've had to replace the FPR o ring twice already. I just can't get it to seat right so it eventually starts seeping. Is there a trick or..?

It's dripping oil off the subframe, under the turbo. I'll look into it tomorrow. Hopefully it's just the drain.

New clunking noise, over bumps and stuff. I kinda get the feeling that something is loose in the rear suspension. I also want to get those metal trailing arm joints and put in the IPD rear swaybar. Currently running 25/stock swaybars with poly bushings in the trailing arms.

Also if you find rear bumper trim in the Simsbury area.. $5 reward..

Cwazywazy is offline   Reply With Quote
Old 01-07-2018, 10:51 PM   #293
esmth
dirty swede
 
esmth's Avatar
 
Join Date: Jul 2016
Location: Massachusetts
Default

Quote:
Originally Posted by Cwazywazy View Post
I've had to replace the FPR o ring twice already. I just can't get it to seat right so it eventually starts seeping. Is there a trick or..?
i've had success using Vaseline on this and my injector o-rings

Quote:
Originally Posted by Cwazywazy View Post
New clunking noise, over bumps and stuff. I kinda get the feeling that something is loose in the rear suspension.
I had a clunking recently that turned out to be slightly loose upper shock bolts. just something to check for

Quote:
Originally Posted by Cwazywazy View Post
Also if you find rear bumper trim in the Simsbury area.. $5 reward..
Funny you should mention this, the other day some dude in a big lifted pickup flew out of a parking space and clipped my bumper, cleanly pulling off the plastic shell and trim and somehow ran over the trim ruining it :(
esmth is offline   Reply With Quote
Old 02-08-2018, 05:19 PM   #294
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default



Time for suspension bushings.

On my way to pick it up, I noticed getting out of second gear was hard if I floor it through said gear.. Might be time for M46 swap soon.
Cwazywazy is offline   Reply With Quote
Old 02-22-2018, 04:03 PM   #295
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Replaced panhard and torque rod bushings, got Kalphenke solid trailing arm joints to install.
Did my M46 swap, now just needs OD wiring. Works great. Shifter feels way better without all that slop.
Also adjustable cam gear so I look like I know what I'm doing. And IPD skid pan, because underside bling.


Cwazywazy is offline   Reply With Quote
Old 04-17-2018, 08:08 PM   #296
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Got sick of the crap side pipe and made a full 3 inch over-axle setup with a small glasspack and a Thrush Hush. I think it came out decent. I had to do over axle because my IPD bar doesn't have the exhaust hoopdedoop.




Cwazywazy is offline   Reply With Quote
Old 05-14-2018, 05:05 PM   #297
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Fuel tank had a rust hole in the side and the filler was straight up duct taped in. I think I overpaid for $700..

Cwazywazy is offline   Reply With Quote
Old 05-15-2018, 02:54 PM   #298
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

That stupid filler neck clamp thingy was a pain and it leaked when I tried to fill it all the way. Any suggestions? Also the tank pump hose was torn.
Cwazywazy is offline   Reply With Quote
Old 06-09-2018, 11:21 PM   #299
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

New intercooler is a nice improvement. Gained about a pound of boost on the gauge after putting it in.



Tried to go around turns quickly. It doesn't like to do that. Both my brand new poly sway bar bushings were ripped in half and clunking around after my first run.

Cwazywazy is offline   Reply With Quote
Old 08-26-2018, 02:24 PM   #300
Cwazywazy
Board Member
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

19t angled flange. Needs more fuel now.

Cwazywazy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:58 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.