home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-02-2020, 09:07 AM   #1
stick70
All the gauges
 
stick70's Avatar
 
Join Date: Sep 2006
Location: North Carolina
Default 93 960 Slow To Start

As the title says, I have a bone stock 1993 960. Not super familiar with the in's and out's of these things, are there any common failure points for me to look at?

The thing runs great always, but starting has gotten slow on it. Sometimes it takes 2-3 tries cranking to get it going, I'm going to go out on a limb and assume it's going to get worse.

A couple of background things, the dual fuel pumps have been replaced with a big single Aeromotive pump and the fuel pressure regulator has been replaced with a new OEM unit, so I know those two parts are not the issue. I have fuel pressure with the key on. This problem has started well after those pieces were replaced anyways, but I have wondered if it could be a leaky injector? No proof to that.
__________________
Kyle and the "Projects" -- '84 242 TI -- '66 220 S -- '60 Coupe DeVille -- '84 Rabbit GTI

Quote:
Originally Posted by towerymt View Post
Cool car. Smells period correct. Would follow through twisties again. A+
stick70 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:54 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.