home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 08-12-2018, 08:32 PM   #1
Overkiller
Newbie
 
Join Date: Dec 2014
Location: Alvin Tx
Default 240 Bosch Distributor Confusion

I've been struggling with my car not running right after a 2.2lh /EZK conversion and I was hoping someone could enlighten me to what distributors I have.

[IMG][/IMG]

On the right is my old distributor I was running with Chrysler ignition before the conversion. It was pulled from a junkyard 240 that I don't remember the year of years ago. After getting the timing set it ran after the conversion, idled well, but acted all kinds of bad when revved. Here's the part number:

[IMG][/IMG]

The distributor was the only part I didn't have a spare of to check and it seemed like a potential culprit for my issue. I ordered the left distributor off ebay described as a 1985-1988.5 LH2.2 240 Volvo 240 Bosch Distributor TESTED WORKS. It showed up and when I went to install it I found my rotor didn't fit, the shaft on my old distributor where the rotor fits is much larger. I got the right rotor, installed the distributor and it does **** all. Here's the part number:

[IMG][/IMG]

You can see the difference in the distributors and I was hoping someone could shed some light on what I have so I can try to get my damn car running finally. Thanks
Overkiller is offline   Reply With Quote
Old 08-12-2018, 10:31 PM   #2
dl242gt
Can play the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

You probably have bad hall sensors in those distributors if the ignition box is correct. Have you double checked the wiring? Both should work to trigger the ezk box. Unlikely both would have bad hall sensors but it's possible.

Are you sure you have the correct EZK 117 box? The numbers can get confusing and they look just like the EZK 116 ignition boxes except that the ezk 116 box is triggered with the engine speed sensor on the crank. So they won't work with a hall sensor.

You don't have to install the distributor to test it. Just connect it up and with the ignition on you can spin the distributor and see if you get spark. Use a spark plug grounded in a plug wire. Don't short the computer ignition plug wires to ground to test.

Last edited by dl242gt; 08-12-2018 at 10:36 PM.. Reason: add info
dl242gt is offline   Reply With Quote
Old 08-12-2018, 10:57 PM   #3
Overkiller
Newbie
 
Join Date: Dec 2014
Location: Alvin Tx
Default

I suspect the wiring was fine, put in a new dave barton harness anyway. I have 3 117 boxes that have been swapped in and out. At this point I can stand across the garage and shoot a distributor in like a free throw. With the distributors being so different I'm just wondering if one is some goofy oddball so I can focus on the other, or if they "should" both work.
Overkiller is offline   Reply With Quote
Old 08-12-2018, 11:23 PM   #4
dl242gt
Can play the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

Connect one up and spin clockwise while having a spark test setup. You can also measure the hall sensor with an ohm meter. I don't know the spec but someone here will know or you can check a haynes or bentley book.
dl242gt is offline   Reply With Quote
Old 08-13-2018, 09:54 AM   #5
2 old for this
Board Member
 
Join Date: Mar 2018
Location: Amarillo
Default

The Windows are different. We went down the same road years back. Look at the spacing of the openings on the wheel under the rotor.
2 old for this is offline   Reply With Quote
Old 08-13-2018, 12:13 PM   #6
dl242gt
Can play the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

That is a good point. I too remember old threads about this because you have to change to a block mount distributor and Volvo didn't give us a block mount car with LH2.2 and EZK117 in a 240. Only the 700 series used it with a head mount distributor. So people here had to figure out which one worked. I don't remember which worked but with some searching the info should turn up.
dl242gt is offline   Reply With Quote
Old 08-13-2018, 02:52 PM   #7
lummert
Board Member
 
lummert's Avatar
 
Join Date: Jan 2008
Location: Portland IN
Default

http://forums.turbobricks.com/showthread.php?t=129382

http://forums.turbobricks.com/showthread.php?t=305592
__________________
Trying to understand stupid people is like trying to pick up a turd by the clean end.
lummert is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:09 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.