home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 05-17-2018, 08:30 PM   #1
hikerguy
Board Member
 
hikerguy's Avatar
 
Join Date: Dec 2012
Location: nepa
Default White Block oil leak behind starter

Ok so I just bought a 1998 v90 with ~140,000m on it. Since I got it last month I've been chasing down a mix of problems but the list is dwindling.

When I picked it up it lost 4 qt. til I got it home ~100 miles. The guy before me said he just put a rear main seal in it because when he bought it the ex owner said it needed it. Once I got it home i found the rear exhaust cam seal missing completely. I blamed that on a shady mechanic trying to get RMS money, but who knows.

I also took the word of a former owner without investigating further and pulled it apart to change PCV. Not needed at all, clean as a whistle. While I had it apart i did notice that the rear starter bolt was not it the hole. I did nothing about this figuring it was replaced with a cheap reman at sometime in its last 20 years.

Car is still leaking oil. It is 100% coming from somewhere behind the starter, but i can't remember ever dealing with an oil issue here on any of mine in the past.

If anyone has a good clear picture of whats behind there, or has any helpful info on this please let me know. This is by far the nicest v90/960 I've owned and it will be the wife's daily.
__________________
+1/2 million miles of white block sitting in the drive way
hikerguy is offline   Reply With Quote
Old 05-17-2018, 08:31 PM   #2
Jack
junkman
 
Jack's Avatar
 
Join Date: Jul 2011
Location: The Ass Cheek Of History
Default

Rear main
__________________
85 245 | 82 242| 75 245| 69 145 |66 122

Make old cars great again

Quote:
Originally Posted by BritishBrick
Don’t bother, I would literally rather throw them away than give you the pleasure. I will never sell to you.
Jack is offline   Reply With Quote
Old 05-17-2018, 08:49 PM   #3
hikerguy
Board Member
 
hikerguy's Avatar
 
Join Date: Dec 2012
Location: nepa
Default

Sight hole for torque converter is oil free. Unless I'm missing something, which is possible but I doubt it on this

Last edited by hikerguy; 05-17-2018 at 08:54 PM..
hikerguy is offline   Reply With Quote
Old 05-20-2018, 09:51 AM   #4
hikerguy
Board Member
 
hikerguy's Avatar
 
Join Date: Dec 2012
Location: nepa
Default

Found the problem.... the moron before me that changed the rms must have had trouble with the starter. The oil leak is coming from the where crankcase comes together. It looks like someone used a prybar and separated the gasket where the trans and case halves come together.

Anyone have an easy fix? I really don't want to explain to the wife that I'm going to have to pull the motor...
hikerguy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:20 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.